Repository navigation
security(PTAAA-847, 852, 863, 876, 491): vite 8.3.5, source-map-js 1.2.2, Node 24.22.1, .npmrc fix - #62
Merged
Conversation
…-js 1.2.1 -> 1.2.2 - vite 8.3.5 fixes GHSA-587h-7wmj-h5pm (launch-editor Windows existsSync bypass, PTAAA-863) plus GHSA-698v-4r3x-3vcv / -r825-w8mm-5pxw / -rq7h-c2jc-7f22 / -9jrq-w75r-8gcw (all fixed in 8.1.6). - source-map-js 1.2.2 fixes GHSA-68fv-2mgg-jv7q (PTAAA-847), via postcss 8.5.31. - braces (PTAAA-852, GHSA-vfj7-8cjw-p6xm) has no patched release (3.0.3 is latest); it only comes in through tailwindcss v3 at build time. Left as is; tracked for a security exception. Supersedes dependabot #59 and #61. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
…ents - PTAAA-876: Node 24.12.0 -> 24.22.1 (October 2026 Node security release, CVE-2026-111497) in .nvmrc (CI reads it via node-version-file), package.json engines and the lockfile root. - PTAAA-491: .npmrc has no inline comments, so `key=true # note` set each value to the whole string and failed the Enigma supply-chain audit. Moved every comment onto its own line; `npm config get` now returns clean values. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
Semgrep p/default (npm-missing-minimum-release-age) blocks the PR now that .npmrc is in the diff. min-release-age makes npm 11.10+ (Node 24.22.1 ships npm 11.19.1) wait 7 days before resolving newly published versions. npm ci installs from the lockfile and is unaffected (checked: vite 8.3.5, build passes). Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
jha-shubham
approved these changes
Oct 27, 2026
Collaborator
Author
|
@coderabbitai review |
✅ Action performed
|
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
What
One PR for the five open security tickets on this repo.
.nvmrc(CI reads it),package.jsonengines and the lockfile root.npmrc# comments→ comments on their own linesbraces: 3.0.3 is the latest release and the advisory has no patched version. It only comes in through
tailwindcssv3 (chokidar,micromatchandfast-glob), at build time, on our own source globs. Removing it would mean migrating to Tailwind v4, which is out of scope for a security bump. We'll request a security exception on PTAAA-852.Lockfile side effects: these all come from the vite bump and nothing else moved.
rolldown 1.2.15 no longer ships the
wasm32-wasibinding, which is why that entry is gone.Supersedes Dependabot #59 (source-map-js) and #61 (vite).
.npmrc: npm has no inline comments, so
ignore-scripts=true # blocks…set the value to that whole string. That's why the audit reportedexpected true, got true # blocks…. Each comment is now on its own line, andnpm config getreturns cleantrue/high/falsevalues.Testing
npm installwith Node 24.12.0, then checkednpm ls: vite@8.3.5, source-map-js@1.2.2.npm ciandnpm run buildpass. The Brotli checknode -p "'BROTLI_DECODER_ERROR_FORMAT_BLOCK_SWITCH' in require('zlib').constants"printstrue.npm config getfor ignore-scripts, strict-ssl, save-exact, audit-level, engine-strict and legacy-peer-deps returnstrue,true,true,high,true,false.engine-strictis now enforced:npm cion Node 24.12.0 fails withnotsup Required: {"node":"24.22.1"}.npm run buildpasses (vite 8.3.5, 2063 modules).npm run lintshows 1 error, the same one already onmain(tailwind.config.tsrequire()). This PR doesn't touch it.Note for the Smart Selection demo
The STS demo compares
demo-tempagainstmain. Once this merges,package.jsonandpackage-lock.jsonwill appear in that comparison untildemo-tempis rebased onto the newmain.🤖 Generated with Claude Code
Summary by CodeRabbit