Skip to content

chore: Merge master into develop - #25833

Merged
andreiborza merged 9 commits into
developfrom
ab/merge-master-into-develop
Oct 28, 2026
Merged

andreiborza merged 9 commits into
developfrom
ab/merge-master-into-develop

Conversation

@andreiborza

Copy link
Copy Markdown
Member

What

Merge master into develop with a real merge commit. There are no file changes.

Why

#25706 was squash-merged, so develop does not have the 11.9.0 release history and every release PR to master conflicts. Merge this with "Create a merge commit", not squash.

s1gr1d and others added 9 commits October 22, 2026 10:44
meta(changelog): Update changelog for 11.9.0
The `nextjs-16 (webpack)` E2E job fails on every branch because
prerendering throws `Could not find the module
".../app/global-error.tsx#default" in the React Client Manifest`. That
comes from a bug in Next.js 16.3.8: its client reference manifest plugin
skips a client component whose webpack concatenated module got the id
`0`, because it checks the id for truthiness. Next.js fixed this in
16.4.0 (vercel/next.js#97936), so this bumps the app's pinned `next` to
16.4.2. 16.3.8 is the last 16.3 release, so there's no 16.3 patch to pin
to instead.

Production module ids are deterministic hashes of the module
identifiers, and those include the pnpm directory names of the loaders.
The job started failing on the same develop commit that had passed a few
hours earlier. The only dependency in the lockfile published in between
is webpack 5.112.1, which changes the peer suffix in the
`@sentry/nextjs` directory name. That's very likely what moved
`app/global-error.tsx` to id `0` on CI. Locally the paths differ, so the
ids differ too. Forcing the id to `0` reproduces the failure on 16.3.8,
and the same build passes on 16.4.2. The `latest` webpack variant
already runs 16.4.x and kept passing.

🤖 Generated with [Claude Code](https://claude.com/claude-code)

---------

Co-authored-by: Claude Opus 5.5 <noreply@anthropic.com>
(cherry picked from commit 6df508e)
Our packages accept `@opentelemetry/api` `^1.9.1` again instead of
`^1.10.0`. We still install and test against 1.10.0.

OTel SDK 2.x only allows `@opentelemetry/api` below 1.10. With
`^1.10.0`, these users get a second API copy, and Sentry spans become
no-op when their SDK registers first.

---------

Co-authored-by: Claude Opus 5.5 <noreply@anthropic.com>
(cherry picked from commit 56f0489)
Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
@andreiborza
andreiborza marked this pull request as ready for review October 28, 2026 15:37
@andreiborza
andreiborza merged commit 0455361 into develop Oct 28, 2026
38 checks passed
@andreiborza
andreiborza deleted the ab/merge-master-into-develop branch October 28, 2026 15:39
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

4 participants