Repository navigation
docs: fix the CocoaPods iOS setup and Android versions in the README - #151
Merged
Merged
Conversation
thomson-t
force-pushed
the
docs/cocoapods-setup-and-android-versions
branch
from
October 27, 2026 17:29
356d72f to
65fd69e
Compare
Following the README's CocoaPods snippet failed to build: the mParticle-Apple-SDK pod declares iOS 15.0 but depends on RoktContracts, which requires 15.6. Show a post_install block that raises any pod's deployment target below 15.6 to 15.6, and add the error to Troubleshooting. Pods that need a later iOS keep their own target. The CocoaPods CI job uses the same block, so it builds what the README shows. The Android snippet still pointed at 6.0.0 of the mParticle Android SDK and Rokt kit while the plugin uses 6.1.9; apps should match it. Co-Authored-By: Claude Opus 5.5 (1M context) <noreply@anthropic.com>
thomson-t
force-pushed
the
docs/cocoapods-setup-and-android-versions
branch
from
October 27, 2026 17:35
65fd69e to
cc1ad0e
Compare
nickolas-dimitrakas
approved these changes
Oct 27, 2026
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Why
Apps that set up the plugin on iOS with CocoaPods by following the README fail to build on current Xcode, because one of the mParticle pods declares a lower minimum iOS version than a library it depends on. The README's Android steps also name an older version of the mParticle Android libraries than the plugin uses. Once this lands, the README's CocoaPods steps build as written and its Android versions match the plugin.
Programme
Follow-up to the 2.3.0 release (mParticle/mparticle-flutter-sdk#147, the Swift Package Manager change, and mParticle/mparticle-flutter-sdk#150, the release), found while checking the published package from new apps. There is no ticket.
What changes
The README's CocoaPods snippet now includes a
post_installblock that raises any pod's deployment target below 15.6 to 15.6 and leaves higher ones alone, and Troubleshooting lists theCompiling for iOS 15.0, but module 'RoktContracts' has a minimum deployment target of iOS 15.6error. The Android snippet moves from 6.0.0 to 6.1.9. The CocoaPods CI job's Podfile uses the same block, so CI builds what the README shows. pub.dev shows the new README with the next plugin release.Linked work
Related: mParticle/mparticle-flutter-sdk#143, the Android update to 6.1.9.
Rollout
Nothing changes in production; if this is wrong, revert the pull request.
Risks
pod installkept the higher targets; we would see a failing CocoaPods job on this pull request.Risk class: low.
Who
Written by: an automated coding agent (Claude Code), at the request of an SDK engineer, after checking the 2.3.0 release.
Code reviewed before opening: an automated review agent; its suggestion to say the
post_installblock replaces the one Flutter generates was applied. A review comment on this pull request, that the block lowered pods declared above 15.6, was addressed by raising lower targets only. No person yet.Design reviewed before opening: no one.
Decision this implements: the requesting SDK engineer asked for this fix on 27 October 2026; there is no public record.
Checked: on 27 October 2026 with Xcode 27, a new Flutter 3.47.7 app using 2.3.0 with Swift Package Manager off failed with the old snippet and built with the
post_installblock, linking each SDK class once and registering the Rokt kit at launch. Withplatform :ios, '16.0'the block raised the pods below 15.6 and kept the two targets at 16.0; a new app's Android build resolvesandroid-core6.1.9.Not checked: Xcode versions before 27, and Flutter versions before 3.47 on Xcode 27.
Size
Hand-written: about 25 lines in 2 files.
Generated: none.